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Introduction 

This document describes source control and how the use it with Domino Designer. On a high level source 

control platforms are described. On a low level setup and usage with Domino Designer are explained. 

After reading this document, you as a developer should decide if source control can be beneficial in your 

projects. This document might give you guidance in taking the first steps. 

Note that in the ‘Lotus Domino Designer User Guide’, section ‘Administering applications’ you can find a 

good introduction about source control enablement. 

Document version 

Date Version Author Comments 

2013-09-04 0.1 Patrick Kwinten Initial Draft 

2013-09-12 0.2 Patrick Kwinten Corrections 

 

Used Sources 

Besides the help topics from the Designer User Guide other sources have been used to write this 

summary document. 

Presentation /Blog 

Title Author 

AD102 : Source Control For The IBM Lotus® 

Domino® Developer 

Declan Sciolla-Lynch 

Integrate Domino Designer with CVS Source 

Control 

Frank van der Linden 

Version Control for Notes developers Martin Jinoch 

Introduction to source control with 

Domino Designer 8.5.3 and Git 

Per Henrik Lausten 

Getting your Git projects back in Domino 

Designer 

Mark Leusink 

 

Video 

Title Author 

Part 1: Installing Mercurial Source Control in 

Domino Designer 9 

Russell Maher 

Part 2: Basic Repo Usage: Committing and History Russell Maher 

Part 3: Connecting To A Remote Mercurial 

Repository 

Russell Maher 

Part 4: Introduction to Source Control Branching Russell Maher 

Part 5: Mercurial Branching and Merging Russell Maher 

Part 6: Using Source Control Tags Russell Maher 

Part 7: Pulling Changesets from a Remote 

Repository 

Russell Maher 
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Part 8: Using Revert and Changing Repo NSF Files Russell Maher 

Part 9: Our Mercurial Source Control Strategy Russell Maher 

NotesIn9 041: XPages, Designer – SOURCE 

CONTROL!!   

David Leedy 

NotesIn9 044: Using Source Control Part 2 David Leedy 

 

Source Control 

What is source control? 

Wikipedia defines source control as "Revision control (also known as version control, source control or 

(source) code management (SCM)) is the management of multiple revisions of the same unit of 

information." 

In other words: source control allows distributed work in teams of any size, at different locations, while 

avoiding conflicts in source code changes. 

Purposes of source control: 

• Ability to capture snapshots of your application as it is developed. 

• Ability to merge code from those snapshots. 

• Ability to track changes to individual elements across snapshots. 

Other advantages source control: 

• More efficient code review. 

• Better linkage with issue and bug tracking management tools. 

• Better data mining of code. 

Source Code Management requirements: 

• Intuitive: 

o A good GUI. 

o Good visualization. 

• Robust. 

• Affordable. 

• Distributed with branching capability. 

• Native windows application. 

• Command line capable. 

• Strong community support. 
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Central vs. Distributed repository 

Central (client/server) 

• Uses a central repository on a server. 

• Requires an active network connection to this server. 

• Higher chance of getting change conflicts when committing. 

• Branching and merging are often more complex. 

• Central repository always reflects the latest version. 

• Developers need to serialize their work. 

System examples 

• Subversion (SVN), CVS, IBM Rational ClearCase, IBM Rational Team Concert, Microsoft Team 

Foundation Server. 

Distributed 

• Each developer has a working copy of the repository locally on their machine (peer-to-peer 

approach). 

• Committing, branching and merging is all done locally (developers can work offline). 

• Can push and pull changes from any other local or remote repository. 

• No central repository means no definitive 'latest version': 

o You can create a server based repository that each person pulls/pushes with. 

o Increases the possibility of merging conflicts. 

• Developers can work independent of each other and merge their work later. 

System examples 

o GIT, Bazaar, Mercurial. 

Terminology (Distributed) 

• Commit (save current state). 

• Diff (show the differences between commits (versions)). 

• Revert (undo (any) commit). 

• Branch (make a new “copy” of the whole app). 

• Switch. 

• Merge (apply changes from one branch to another). 

• Branch. 

• Tag. 

• Clone. 

• Pull. 

• Push. 
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Source Control in DDE 

Classic way 

 

Disadvantages: 

• No easy way to get back to previous state unless we are keeping: 

o Backup versions of design elements. 

o Backup copies of the whole template. 

• We don't know what the last change was. We need to maintain this information in a separate 

change log. 

From DDE 8.5.3 

From 8.5.3 source control enablement it is built-in to DDE. It lets you store NSF based design elements 

into a source control repository and perform common source control operations using Designer. The 

feature does this by letting you create an association between an on-disk project managed by the source 

control and the virtual NSF based project that Designer tracks. 

o Version control systems need real files to act on, not virtual file system. 

o Some design elements have to be converted to DXL. 

The feature lets you integrate an SVN source control client with Designer as seamlessly as possible and to 

let Designer stay “agnostic” to each source control system as much as possible. 

The figure below visualizes how changes in a Notes application (NSF) are synchronized (automatic by 

default) with a SCM system via an on-disk Eclipse project and vice versa. 
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NSF On-disk project Source Control system 

This is where you (typically) do 

all your development. 

Basically a local backup of the 

database; not associated to any 

particular source control tool. 

 

 

Note: It is the on-disk project which is under source control management. 

Managing source code requires a tool: 

• Install in Domino Designer (as an Eclipse plug-in install). 

o Examples: Mercurial for Eclipse, SVN for Eclipse, Egit. 

• Install outside of Domino Designer. 

o Examples: TortoiseCVS, TortoiseSVN, TortoiseGit, CVS. 

• Install on Mac if you run Windows in a VM. 

o Examples: Sourcetree, Tower. 

 

Why do you want source control in DDE? 

• XPages development requires a more structured approach to release control than classic Notes. 

• Move towards a more modular approach to applications. 

• More often multi-developers way of working. 



8 

 

Configure DDE for source control 

In order to be able to use source control in DDE you need to install plugins. You will need to be able to 

install from an update site.  

o Go to the 'File → ApplicaQon → Install' menu. 

If you don't see this menu option you need to enable it in your DDE preferences. 

 

o EGit for DDE based on current EGit for Eclipse 3.6 and higher. 

o Subversion Update Site for DDE. 

o Mercurial; choose 1.6.0 version of Mercurial Eclipse plugin and 1.4.3 version of Mercurial 

Binaries. 

Enable source control for NSF 

o In DDE select an application and select ‘Team Development → Set Up Source Control for this 

Application...’ 
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o Select ‘Next’: 
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o Enter a name for the project: 
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Note: Never, ever, ever create this to an existing folder. It deletes all content in that folder before 

exporting the NSF. Simply just accept the default option.  

o Select ‘Finish’. This creates an on-disk Eclipse project of the source code in the application (NSF). 

Automatic import/export 

In Domino Designer you can disable automatic import / export to the on disk project, under ‘Domino 

Designer → Source Control’. Here are two checkboxes for import and export.  
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The best way to think of this is that the on disk project is effectively a local replica of the database. If 

those preferences are checked, then it’s like after making any change to each design element, replicating 

to your local replica and waiting until the replication has completed before doing anything. It will have 

minimal impact if you’re working on local NSFs only. But if you’re working with server-based NSFs, you 

don’t need it, so disable it. All you have to do is get into the habit of manually syncing, by using ‘Team 

Development → Sync with On Disk Project…’. 

Install EGit to DDE 

o Download the EGit for IBM Domino Designer plugin at 

https://www.atlassian.com/software/sourcetree/overview.  Information about the plugin 

project you can read here: 

http://www.openntf.org/internal/home.nsf/project.xsp?action=openDocument&name=EGit%20

for%20IBM%20Domino%20Designer. 

o In DDE select ‘File →  Application →  Install…’: 
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o Choose ‘Search for new features to install’: 
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o Point it to the downloaded zip file: 
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o Check ‘org.openntf.egit.update.zip’ and press ‘Next’: 
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o Accept the term in the license agreements: 
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o Press ‘Finish’. Keep accepting (there is one more dialog asking for permission to install plugin) 

and then restart Designer. 

 



18 

 

 

Set up Git for the on-disk project 

o Select the project in the Navigator Eclipse view perspective. 

o Choose ‘Team →  Share Project…’: 
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o Select Git as repository: 
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o Configure a repository for GIT: 
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o Start using Git directly from DDE: 
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o Alternatively you can use command line in Git Bash (http://jinoch.cz/using-git-domino-designer-

hardcore-way). 

Install CVS 

o In DDE select ‘File → ApplicaQon → Install…’: 
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o Specify the Ganymede update site. 

o Add as Remote location: 

o URL is http://download.eclipse.org/releases/ganymede/ 
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o Click 'Finish' to start searching for software to install. 

o Select the required mirror site or leave it as is: 
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o Click ‘OK’. 

o Select under Collaboration tools the CVS connectors. 

o To get all the depending connectors, click the button ‘Select Required’. 

 

o Click ‘Next’. 

o You need to accept the license of the connectors: 



26 

 

 

o Click ‘Next’. 

o You get an overview of all the plugins to be installed: 

 

o Click ‘Finish’. 

o The connectors are being installed, this can take some time. 

o Restart Designer. 
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Set up CVS 

o In DDE open the CVS Repository Exploring perspective. The perspective can be found via 

‘Window → Open Perspective → Other’: 

 

o Click the CVS icon on top of perspective: 

 

o In the popup add the host and repository path of source control (CVS): 
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o If Authentication is required, provide User and Password. 

o Click ‘Finish’. 

o If the connection is correct, the root of the source control system will be displayed: 

 

Set up CVS for the on-disk project 

o Create an on-disk project. 

o Right click on the project name in Domino Designer Perspective. 

o Select ‘Team Development → Set Up Source Control for this Application’: 
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o You will get a Helper panel, with some information about the setup. 

o If you don’t want this in the future, tick the checkbox at the bottom: 

 

o Fill in the project name: 
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o Use the default location in the data\workspace directory or specify a custom location to store 

the on-disk project. 

o Open the Navigator view via ‘Window → Show Eclipse Views’. 

o There is the new on-disk project: 

 

o Next share the on-disk project with source control. 

o Right mouse click and select ‘Team →  Share Project’: 
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o Select the Repository type, select ‘CVS’: 

 

o Click ‘Next’. 
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o Use the newly created repository location or create a new one: 

 

o Click ‘Next’. 

o Select the location on the source control server: 
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o Keep the checkbox ‘Use project name as module name...’ selected. 

o Click ‘Next’. 

o An overview of all the design elements that will be committed is presented: 

 

o Leave the ‘Launch the Commit wizard’ checkbox selected. 

o Click ‘Next’. 

o Commit the files. 

o Enter comment for the Commit operation. 

o This should be a meaning full description of this commit operation. 
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o Click ‘Finish’ and the commit operation will start directly. 

o In the CVS Repository exploring perspective you can see if everything went well: 

 

Install Mercurial in DDE 

Preparation 

o Visit site: http://mercurial.selenic.com/downloads/ 

o Use version 1.6.0 MercurialEclipse. 
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o Use version 1.4.3 Mercurial Binaries. 

Installation 

o In DDE select the option to install new features: 

 

 

o Then add a new update site: 

 

o Complete the details for your selected SCM package. 

o Click 'Finish' to start searching for software to install. 

Mercurial Eclipse requires an older version 

o De-select the following option: 

 

o The older version can now be selected: 

 

o Once selected click 'Next' and follow the prompts to install the update site. 
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o Restart Designer client when prompted to activate the new plugins. 

 

o You can verify that the plugins are installed via ‘File → ApplicaQon → ApplicaQon 

Management…’: 

 

Set up Mercurial for on-disk project 

o Select the project in the Navigator Eclipse view perspective. 
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o Choose ‘Team →  Share Project…’: 
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Actions in DDE with source control 

Synching 

Before you can commit changes to the source control you need to synch the changes in the NSF with the 

on-disk project. 

o Make changes to the database: 

 

o Right mouse click. 

o Select ‘Team Development → Sync with On-Disk project’: 
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o Open the Navigator view via ‘Window → Show Eclipse Views’. 

o The arrow before the on-disk Project indicates there are changes to commit: 

 

o Right mouse click on project. 

o Select ‘Team → Synchronize with Repository’: 
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o A warning of switching perspectives will be presented: 

 

o If don’t want this warning in the future, select the checkbox ‘Remember my decision’. 

o The Team Synchronizing perspective opens. 

o It gives an overview of all the changes. 

o Right click on project name and select ‘Commit’: 
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Committing (Mercurial) 

o Before making any changes you should do an initial commit. 

o Then you should commit changes every time you make a change and have tested it. 

o A change can consist of one or more design elements. 

o You should always enter in a good description of the change. 
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After the Commit operation, the changes have disappeared from the perspective: 

 

As you commit changes a revision history of the application is built up: 

 

You can use the 'History' panel to see this by using the 'Team → Show In History' menu. 

The revision history also shows what design elements changed for the selected Changeset: 
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Double clicking on a design element in the history will show you the differences:  

 

Handy when you want to remind yourself of exactly what changed at a later date. 

Reverting (Mercurial) 

Think of it as an Undo for multiple changes. 

Two types of reverting: 

o Reverting changes before they are committed. 

o Reverting to an older Changeset. 

Select 'Team → Revert' to start the process. 

If there are uncommitted changes they will be listed: 
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If you have not made changes since last commit then you need to select an older revision: 
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Rollback 

Undoes the last action you took. 

Backout 

o Remove a single Changeset from the middle of the repository.  

o May result in a conflict that will need to be resolved. 

Stripping 

o Removes all Changesets back to the selected Changeset. 

o Destroys the true history of the repository. 

o Stripped Changesets cannot be recovered. 

Branching (Mercurial) 

o Branching allows you to have multiple versions of an application within the same code base (e.g. 

customer specific). 

o A great way to try out new code without affecting other branches. 

o A developer may create an 'experimental' branch to try out a new way of doing 

something. 

o Or create a new branch for each new version of the application. 

o Some developers could be working on maintaining the V1 branch. 

o Some developers could be working on new features for the V2 branch. 



53 

 

o Branches can also be further branched as required. 

 

 

As you commit changes to the branch the history graph will show the new branch: 
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Branching (CVS) 

o Create a branch of the project. 

o For example with customer specific design elements: 

 

o Sync database with On-Disk Project: 

 

o Switch to the Navigator perspective. 

o Right click project. 

o Select ‘Team → Branch…’: 
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o Fill in a Branch Name. 

o And a Version Name: 

 

o Click ‘OK’. 

o In the CVS Repository perspective the branch has been created: 
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o The new changes are not present yet. 

o Switch to the Team Synchronizing perspective: 

 

o Commit the new changes to the branch. Right click the project name: 
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o Comment the commit operation: 

 

o Click ‘Finish’. 

Switching 

Use the 'Switch To' menu to change between branches: 
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Select where you want to switch to, it doesn't have to be a branch: 

 

After switching, the repository will be updated to reflect that revision. 
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Then the 'NSF ↔ On Disk Project' sync will kick in and the NSF will be updated to reflect the on disk 

version. 

If there are a lot of differences in the revision you have switched to this process can take a few moments. 

Merging (Mercurial) 

o Taking the changes made in one branch and applying them to a different branch. 

o Bug fixes in the V1 branch can be merged into the V2 branch. 

o The experimental branch can be merged into active development branch. 

o Merging branches is often easy but edge cases can be tricky. 

o A design element deleted in one branch but changed in another branch. 

o A design element changed in the same place in both branches. 

o Not 100% automatic, the developer needs to be involved. 

o Merge conflicts need to be resolved before the merge can complete. 

o Binary files like images can't be merged so a winner needs to be selected. 

o Developer should fully test the resulting code before committing the final merged 

results. 

o Developer can reverse the merge by not committing it to the repository. 
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Merging (CVS) 

o Branches can also be merged together. Right mouse ‘Team → Merge’: 

 

o The Synchronize perspective will open: 

 

o It shows the modification who will commit to the base. 

o Right click ‘Merge’: 
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o Two branches will be merged together. 

Tagging (Mercurial) 

o As the repository history gets bigger it gets harder to find a specific revision. 

o Tagging allows you to assign a name to a specific revision. 

o When you make a new release to production tag the revision with the version number. 

o Tag your alpha, beta and Release Candidate revisions. 

o Tags don't take up resources so don't hesitate to use them. 

o Tags can be reassigned but this is a bad practice. 

o Some source control systems allow you to move a tag to a different revision. 

o Destroys the true history of the repository. 



66 

 

 



67 

 

 

 

Tagging (VCS) 

o Tag as Version. 

o Can switch to a other version or branch. 
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Cloning (Mercurial) 

o Cloning a repository creates a copy of a remote repository on your local machine. 

o Normally done when a new developer joins a team. 

o The clone remembers where it originally came from so you can later pull and push 

changes. 

o Cloning just creates the 'on disk' version of the application. 

o The developer can then create a real NSF/NTF to work in. 

o The initial clone process can be slow for a large project. 

Start the process in the Package Explorer by creating a new project: 

 

Select your Source Control system from the list of wizards: 
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Pulling (Mercurial) 

o Pulling updates your repository with Changesets from a remote repository. 

o Only Changesets you are missing are transferred. 

o As a general rule you should always commit your own changes before pulling in additional 

Changesets. 

o If you pull Changesets into the same branch your currently working in then you should do a 

merging pull. 
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Pushing: 

o Pushing will send your changesets to a remote repository. 

o If your repository has new branches you may have to select the 'Force' option. 

 

You can also elect to only push up to a certain revision, later revisions will not be pushed to the remote 

repository: 
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Get data out of source control (CVS) 

o Open the CVS Repository perspective. 

o Right click the project. 

o Select ‘Check Out As…’: 

 

o It will be associated to on on-disk Project. 

o If there is no on-disk Project you can also choose the New Project wizard: 
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o Click ‘Finish’. 

o In case an on-disk project already exists, there will be a warning about overwriting the on-disk 

project: 
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o Choose ‘Yes’ or ‘No’. 

o Switch back to the Domino Designer perspective. 

o Right click on the application. 

o Select ‘Team Development → Associate with Existing On-Disk Project’: 
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o Select the on-disk project to associate the database with: 

 

o Click ‘Finish’. 

o All the design elements are loaded in a new application: 
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Get data out of source control (eGIT) 

In case you need to re-add your on disk projects to and restore the connection with the NSF´s below is 

described is how. 

• If needed re-install Designer. 

• If needed re-install the eGit plugin.  

o By default, eGit stores the GIT repositories on Windows in a directory called “git” in the 

users’ home folder (c:\users\<your name>)*. An uninstallation of Designer will not 

remove that folder, so your on-disk projects are still there.  

Note: Add this folder to your backup! 

• Add your databases to Designer and organize those using working sets.  

You then need to get the Git projects back in Designer: 

• Go to the Package Explorer, right click somewhere in it and choose ‘Import’.  

• Enter “git” in the search dialog and select the ‘Projects from Git’ option.  

• Select the Git repository (folder) that contains your project (or click ‘Add’ to select the location of 

the repository on the file system).  

 

• In the next screen, leave the ‘Import existing projects’ option enabled and select the ‘Working 

Directory’ folder.  

• Click ‘Next’ and Designer will show you the on-disk projects it contains.  
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o Select the ones you would like to import. I would suggest selecting the working set you 

chose for your database, but for some reason I wasn’t able to select it, so I added the Git 

project to the working set afterwards using the method described here.  

• Click ‘Finish’. 

You’re now ready to restore the link from your databases/ applications with the on-disk project:  

• Right-click on a database and select ‘Team Development > Associate with Existing On-Disk 

Project’.  

o If you have the latest design sitting in your database, choose the ‘Export from 

database.nsf to selected on-disk project’ option.  

o If you want the on-disk project to be leading, choose the ‘Import …’ option.  

• Select the on-disk project you just imported and hit ‘Finish’.  

• Done. Now back to work! 

Note: It looks like there’s a bug the eGit version used in Designer that causes eGit’s repository views to 

sometimes be completely blank. No fear: click the menu icon next to the view and select ‘Refresh’. 

Note: If you create an on-disk project for a database, all files are stored (by default) in <notes 

data>\workspace\<project name>. If you then add that local on-disk project to eGit using Team > Share 

project, the entire folder is moved to the default eGit folder at c:\users\<your name>\git\<new repo 

name>. 

Best practices 

• Disciplined approach. 

• Commit related changes. 

• Commit often. 

• Don‘t commit half-done work. Only commit REAL changed. 

• Test code before you commit. 

• Write good commit messages. 

• Version control is not a backup system (so don't use it for auto-committing on a schedule). 

• Use branches. 

• Agree on a workflow. 

Tips for DDE 

1. Always use your own COPY of the database to develop in (using a replica or shared DB causes 

issues). 

a. Using a replica or shared DB causes issues 

b. Your design changes are your own till you pull/merge in other changes. 

2. If possible run a local development server and work from that. 

a. Really speeds up Domino Designer. 

3. (Never work directly against your production environment). 
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Steps (hand-on)  

TBD 

• Create application 

• Create on-disk project 

• Share on-disk project (initial commit) 

• Committing additional changes 

• Editing source code in the on-disk project (outside of DDE) 

• Adding source code to the on-disk project (outside of DDE) 

Appendix A – List of Terms 

DDE Domino Designer on Eclipse 

NSF Notes Structured File, physical file where design 

and document notes are stored. 

SCM Source Code Management 

  

  

  

  

  

  

 


