Question on Domino Blog Template – Show full entry in RSS not working

Hi, I am facing a problem with getting full entries in the RSS feed for the blog template. Basically if I select ‘Yes’ as option the feed becomes empty.

You can read a description of the option here:

http://www.stevecastledine.com/sc.nsf/dx/ibm-lotus-notes-blog-template-rss-options?opendocument

Show Full Entry in RSS? (Content Encoded)
Default is “No”. If set to “Yes” then full content is sent with RSS feed rather than just a short abstract.

If I dig down in the agent (feed.rss) I read it uses the scriptlibrary DXRSS. In Sub StreamRSS2 I read:

If configdoc.config_rssfull(0)<>”No” And contentdoc.excludecontentrss(0)<>”Yes” Then

But an else statement is never further defined.

So I just wonder if the full entry option is ever implemented? The template we are using is the STd7Blog template delivered with 8.02. Are there upgrades available for the template?

Thanks in advance for your help.

Advertisements

5 thoughts on “Question on Domino Blog Template – Show full entry in RSS not working

  1. Stuart McIntyre 2010-May-17 / 11:01 pm

    Not sure this will help you much Patrick, but this option has always worked for me on 7.0.2, 8.0.x and 8.5.x – we have always used the full post in our RSS feeds and have advised many others to do the same.

    Probably teaching granny to suck eggs here, but have you tried a new DB created from a vanilla copy of the template?

    Also, have to checked the feed in multiple feed readers – I’ve had issues where the DominoBlog RSS feed has been a little variable – particularly in the newest browsers – putting it through FeedBurner has helped in this situation.

  2. Patrick Kwinten 2010-May-18 / 8:49 am

    well I downloaded the latest template version from OpenNTF and replaced the design of an existing blog with it, but the full entries option still results in an empty feed πŸ˜•

  3. Stuart McIntyre 2010-May-18 / 8:53 am

    And did you try creating a new blog? Reason I ask is that perhaps one of your existing blog entries has a corruption or invalid HTML?

  4. Lars Berntrop-Bos 2010-May-18 / 12:03 pm

    Just looked at the lib ion 8.5.1 server, lib is dated 23-9-2008. Look at: Number of Latest Items for Feed: (config_rssno)
    Also, the content (i.e. the post itself) also has to have excluderss set to something other then “Yes” to be shown in the feed.
    I can also see that a lot ogf content already has been printed before the statment you refer to has been reached. And to my mind, this is the statement that if true prints the full RSS, i.e. the summary has already been done…

    • Patrick Kwinten 2010-May-23 / 5:13 pm

      According to my experience a change in the settings do not have effect unless you re-save your documents with the new setting.

      Sometimes I even had to copy the content in new documents in order to have the feed successfull.

      Not a setting you want to switch during production… πŸ˜•

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s